Se você usa WordPress e recebeu o mesmo aviso abaixo que é necessário atualizar o PHP e assim como eu ficou com receio, vou mostrar um plugin para scanear e verificar a compatibilidade dos temas e plugins que estamos utilizando.

Aviso Sopre Atualização do PHP do WordPress

Aviso Sopre Atualização do PHP do WordPress

Para quem não sabe o que é php é a linguagem de programação utilizada para desenvolver o WordPress e seu plugins. Para que o WordPress funcione é necessário que o servidor tenha suporte a linguagem php. No caso da imagem acima, a versão está muito antiga o que representa riscos de vulnerabilidades, brechas para atacantes e por isso aparece a mensagem de atualização necessária para garantir um nível maior de segurança.

Antes de atualizar o WordPress, garanta que seu tema e seus plugins sejam compatíveis com as novas versões utilizando um plugin tal como o que vou mostrar abaixo que é o “PHP Compatibility Checker”.

Link Para Download: https://br.wordpress.org/plugins/php-compatibility-checker/

Antes de atualizar a versão do PHP, faça um backup geral. Se não saber como fazer isso, acesse o link abaixo e aprenda para garantir uma cópia completa do seu site ou blog caso algo saia errado:

Como Configurar Plugin de Backup Grátis Para WordPress: https://www.servti.com/blog/2017/05/19/plugin-backup-wordpress/

01 – Instale o plugin “PHP Compatibility Checker”;

Aprenda como instalar Plugins no WordPress: https://www.servti.com/blog/2019/08/31/como-instalar-plugins-no-wordpress/

PHP Compatibility Checker

PHP Compatibility Checker

02 – Vá até o gerenciador de plugins, ache o PHP Compatibility Checker e clique em “Start Scan”;

Start Scan

Start Scan

03 – Escolha a versão do PHP que desejar que o plugin verifique a compatibilidade, escolha a opção dos temas e plugins. A Opção de temas e plugins que escolhi significa (Apenas scanear temas e plugins ativos), por fim, clique em “Scan site”;

Selecione as Opções do PHP Compatibility Checker

Selecione as Opções do PHP Compatibility Checker

04 – Aguarde um pouco até o teste terminar. O tempo de termino depende da quantidade de plugins que você tem instalado e a quantidade de espaço que esses plugins estejam consumindo;

PS: O resultado por enquanto só está disponível em inglês. Qualquer coisa, traduza no Google ou em qualquer outro software que desejar. No meu caso foi apresentada a mensagem: Attention: Not all errors are show-stoppers. Test this site on PHP 7 to see if it just works! (Atenção: Nem todos os erros são parados. Teste este site no PHP 7 para ver se funciona!

Resultado do Scaneamento do Selecione as Opções do PHP CompResultado do Scaneamento do PHP Compatibility Checkeratibility Checker

Resultado do Scaneamento do PHP Compatibility Checker

Como podem ver acima, não houveram erros críticos e foi informado que o site é compatível com a versão 7.0 do PHP. Para mudar, você tem que ir na hospedagem e mudar a versão.

Como Mudar Versão do PHP na Sua Hospedagem: https://www.servti.com/blog/2019/08/31/como-mudar-versao-do-php-na-sua-hospedagem/

Obrigado por sua visita.

Curta nossa fanpage em: www.facebook.com.br/servicoti

Acesse também nosso canal no YouTube: Canal Servti